Troubleshooting JIRA Integration for Metrics

Overview

This article serves as a comprehensive guide to JIRA metrics configuration and how data is extracted to provide metrics values using the Metrics app in Crossover. If you are a contractor that expect different values or find JIRA tickets not being counted in metric, you will need to discuss with your manager.

It can take 4 to 6 hours for metrics to populate/update from JIRA. If there is a discrepancy between the expected tickets from JIRA and the Crossover metrics, the first step is to give it the necessary time to populate.

 

Prerequisites

  • Team Room owner with metrics set up for the team using JIRA.

 

Diagnosis

Metric values are not being updated at all or after attempting to refresh the metric values, you will find out that the value received for a contractor is not the one expected based on your JIRA view.

 

Solution

  1. Always review our article for Configuring Metrics with JIRA as Source to confirm that the metrics are set up as expected. If you are not the team room owner, please reach him to review this information.
  2. If you are unable to refresh the team metrics, you should always try first to access your JIRA server and confirm that you can browse through your team members' tickets. Additionally, you may need to review our articles for server connection problems and integration account blocked.
  3. If you find out that there is one specific contractor that doesn't have any values collected but you confirm in JIRA that there are tickets that should be retrieved, this usually means that the contractor's JIRA ID is not set up in the metrics configuration.
  4. While retrieving JIRA metrics for contractors, Crossover backend uses the JIRA integration account timezone setting in JIRA and the query defined in the metric configuration. If you notice that there are differences in the numbers that you retrieve using JIRA and the ones that are displayed by Crossover you will need to:
    • Confirm that your profile timezone setting in JIRA matches the timezone settings of the integration account, if they are different you will need to adjust your JIRA query.
    • You might be using a different query in JIRA than the one used by the JIRA metrics settings in Crossover. You can check the JIRA query used by Crossover by following the Reviewing JIRA Metrics Query article.

 

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