Overview
As an active contractor, you may notice that the WorkSmart application is not taking screenshots as expected, meaning that there is no image found, an incorrect number of screenshots found or other issues experienced while using multiple monitors.
If images are not showing up in your dashboard, you will need to confirm that you have the latest WorkSmart version installed and that your manager set up the screenshots for your assignment.
Prerequisites
- Active contractor using WorkSmart to track time.
Diagnosis
You can access your logbook in the Crossover Contractor Dashboard and confirm that there are missing screenshots images or that the image displayed is not the expected one:
Solution
- Be sure to download and install the latest WorkSmart version.
- Ensure that your operating system has all the latest updates installed. Check the WorkSmart System Requirements article.
- If you are running WorkSmart under Linux operating system, please notice that it's now unsupported and you should switch to macOS or Windows.
- If you are running WorkSmart under macOS operating system, you may need to reset all your permissions in macOS:
- Open a terminal window.
- Execute the command:
$ sudo tccutil reset All
- Restart your computer.
- Open WorkSmart and grant the rights under Accessibility, Automation and Screen Recording:
- Confirm that your assignment information shows that the screenshots are enabled for you:
You should have a green check next to the webcam icon, if there is a red mark, please contact your manager and let him know that screenshots are disabled for your assignment.
If you hover your mouse pointer over that image, you will be able to review a tooltip showing the number of screenshots set up by your manager: - If you are still having issues, you will need to collect WorkSmart logs:
- On Mac, zip and attach the contents of the folder:
HD/users/<user>/crossoverfiles/logs
- On Windows, zip and attach the contents of the folder:
C:\Users\<user>\AppData\Roaming\CrossoverWorkSmart\Logs
- Create a new ticket for Crossover Support, attaching the zip file containing WorkSmart logs.
- On Mac, zip and attach the contents of the folder:
Confirmation
You can confirm that the screenshots are being taken by reviewing your logbook in the Crossover Contractor Dashboard and confirm that the images are the ones generated by WorkSmart:
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