Discontinuation of WorkSmart Support for Linux

Overview

Crossover has decided to temporarily discontinue the technical support provided for WorkSmart under the Linux operating system, this includes all distributions, like Ubuntu, Fedora, Chrome OS, etc. This means that there is no available version for Linux, only Windows and macOS WorkSmart versions are available for download.

We will keep you updated as soon as we have any news for official WorkSmart Linux support, contractors will not have the option to download the Linux client and we cannot provide any support for old WorkSmart versions.

 

Prerequisites

  • Active contractor using WorkSmart to track time.

 

Solution

At present, we are not certifying new Linux builds for release as we are working with Central Services in unifying our client software and increase our automation coverage.

In the meantime, if you are still using a WorkSmart Linux client, you may continue doing so; however, we will not provide official support to any malfunctions or defects that only affect the Linux platform. If you need to download a new client, please switch to one of the supported WorkSmart versions.

 

Related Articles

Comments

12 comments

  • Avatar
    Siarhei Hromau

    I troubleshoot the WS tool on my Fedora with Gnome and have found it requires a system tray for a correct work. However, it is missing in Gnome. The installation of Topicons Redux Gnome Shell extension which simulates a system tray fixed the compatibility issue for me.

    2
    Comment actions Permalink
  • Avatar
    Eduardo José Rosales Alconero

    Were can I download one of the previous version? I have a new laptop to improve my work but I had to stick with my old laptop instead since I don't have the Work Smat installer for linux.

    6
    Comment actions Permalink
  • Avatar
    Juan Pagola

    The main steps i took to make it work in Ubuntu 18.04 are:

    1-install java 8 and set as default
    2-Switch to unity: sudo apt install ubuntu-unity-desktop
    3-On the crossover folder: chmod a+x crossovertool.bin; ./crossovertool.bin

    And then you just have to execute it via terminal with ./Crossover.

    2
    Comment actions Permalink
  • Avatar
    Joe Kern

    Juan,

    Has this been working well for you on 18.04?

    0
    Comment actions Permalink
  • Avatar
    Juan Pagola

    Joe,

    It has been working fine, i sometimes see like no time is being recorded, but its always there on my Logbook, after a couple of hours it syncs back with the desktop tool.
    Keep in mind i been only using this on Ubuntu since Monday.

    0
    Comment actions Permalink
  • Avatar
    Pasan Chamikara

    Any update regarding the matter?

    1
    Comment actions Permalink
  • Avatar
    Eduardo José Rosales Alconero

    "We are hoping to launch an area soon where we can post all of the historical versions of the tracker for download in case they are needed."

    When will be this area available? Just as now the Worksmart Linux client has been push again from Q1 2019 to Q4 2019, and this area will be needed so we have a way to use Worksmart client on linux.

    3
    Comment actions Permalink
  • Avatar
    Alexei Mahanov

    I would like to stick with my linux OS as well. Can you please provide a link to the latest available WorkSmart for linux build.

    3
    Comment actions Permalink
  • Avatar
    Brian Dale

    So Crossover contractors using Linux just can't run WorkSmart at all?

    This is ridiculous.

    0
    Comment actions Permalink
  • Avatar
    Mikhail

    The link was removed, but the file is still present: just take the link for windows and replace .exe -> .bin

    https://s3.amazonaws.com/crossover-clients/crossovertool.exe

    ->

    https://s3.amazonaws.com/crossover-clients/crossovertool.bin

    I was able to download and install the tool on ubuntu 18.04.2 (thanks to Juan Pagola's comment above). Tool's version is 20170316. When I try to login I get "Incorrect user name or password" though I provide correct credentials.

    Upd: I was not assigned to the team at that moment. Everything works perfectly.

    0
    Comment actions Permalink
  • Avatar
    Pasan Chamikara

    Is there any update regarding this. It's almost the end of 2019.

    1
    Comment actions Permalink
  • Avatar
    Siarhei Hromau

    I found it does not work on Java 11. Guys, use the lower version.

    1
    Comment actions Permalink

Article is closed for comments.