Overview
After installing WorkSmart successfully on macOS and once you started tracking time, you may receive the following error message: "Worksmart is not able to write time card data to disk. This may impact your reported earnings.".
This issue can be resolved after granting Full Disk Access to the WorkSmart application in macOS.
Prerequisites
- The latest version of WorkSmart for macOS is installed
Diagnosis
While tracking time with Worksmart on macOS, you might receive the following error:
Worksmart is not able to write time card data to disk.
This may impact your reported earnings.
This issue is caused by missing Full Disk Access permissions for the WorkSmart application, the user must have administrator access in macOS in order to grant them.
Solution
- In your macOS, access System Preferences -> Security & Privacy -> Privacy -> Full Disk Access. Click on the plus sign to add an application:
- Select Crossover from the list of applications:
- Click on Open.
- If you are currently running WorkSmart, you will need to click on Quit Now to make the changes:
- You will need to open WorkSmart and start tracking time.
Confirmation
Once you start tracking time with WorkSmart you won't receive any error messages. Wait for 30 minutes for the application to upload timecards and confirm that you can review them in your logbook.
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