WorkSmart Hangs on Updating to Latest Version

Overview

While trying to launch WorkSmart, you may find out that the application hangs and the following message is displayed: "Updating WorkSmart to latest version".

You won't be able to start WorkSmart successfully because of a faulty update installation, in order to resolve this issue, you will need to uninstall and install latest WorkSmart version.

 

Prerequisites

  • Active contractor using WorkSmart to track time.

 

Diagnosis

After starting WorkSmart, you will find that the following message keeps on showing on the screen: Updating WorkSmart to latest version.

Screen_Shot_2018-07-03_at_14.png

 

The reason for this behavior is a previous faulty update on WorkSmart, which causes the application to hang during the automatic update performed after the start.

 

Solution

  1. Uninstall WorkSmart application
  2. Follow the solution from the Downloading and Installing WorkSmart article.

 

Confirmation

WorkSmart will execute successfully and the login screen will appear:

mceclip0.png

 

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