Overview
WorkSmart application closes immediately after launching it on macOS if there are any issues while trying to retrieve the available webcams. This problem is usually generated by external webcam plugins/drivers (like EpocCam) or if the user's local account is managed using an MDM profile.
Prerequisites
- The latest version of WorkSmart for macOS is downloaded.
Diagnosis
- Attempt to launch WorkSmart using macOS:
- You will notice that the WorkSmart icon can be seen, no window is opened and then the WorkSmart icon will disappear:
This issue is related to WorkSmart not able to retrieve the list of available webcams for the user's computer.
This may happen if the user's local account is being managed using an MDM profile, which blocks the user's account from running the WorkSmart application with full administrator rights. Also, it's possible that an external webcam plugin is preventing WorkSmart from retrieving the available webcams.
Solution
- Remove MDM profile: MDM profiles are usually administered by an organization, such as a business, and may require that organization's assistance to remove it.
- Create a new user account on macOS: if it's not possible to remove the MDM profile or if WorkSmart is not working after removing it, please create a new user account on macOS, this will guarantee that WorkSmart is launched with administrator rights.
- Remove webcam plugins/drivers: if you have any webcam plugins or external drivers installed (like EpocCam), please remove them.
Confirmation
You will be able to run the application and you will receive the License Agreement message:
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