Overview
This article serves as a comprehensive guide to how Google Sheets is configured and formatted to provide metrics values using the Metrics app in Crossover. It also provides a checklist of additional information that helps you to troubleshoot metrics-related issues.
It can take 4 to 6 hours for metrics to populate/update from a Google Spreadsheet. If there is a discrepancy between the sheet and the Crossover metrics, the first step is to give it the necessary time to populate. Follow the troubleshooting steps below if the metrics are still incorrect after that time.
Prerequisites
- Team Room owner with metrics set up for the team using Google Sheets.
Diagnosis
Metric values are not being updated at all or after attempting to refresh the metric values, you will receive an error message like "Oops! Something went wrong :( We weren't able to process your request due to an internal error".
Solution
- Metrics App
- Permissions
- Check Dates Incongruences
- Additional Information
- Support Agents - Configuring the Testing Datasheets With Customer Data
Metrics App
Metrics can be set for every Team room. This means that every Team room can have its own metric settings for Google Sheets. Usually, you have two options:
- One Google Sheet for each Team room, which means, three Google Sheets for three different Team rooms, or
- One Google Sheet for all the Team rooms, with one tab per Team room. For example, one Google Sheet with three tabs for three different Team rooms.
A good example of how the metrics Google Sheet file should look is shown below:
- The tab name is MetricsForTeam1 (If you choose to have just 1 Google Sheet for all your Teamrooms, there has to be 1 tab per Teamroom).
- After the Email column, you can find the values that are supposed to be shown on the Teamroom metrics.
- There is a thick vertical line between columns C and D, which means that everything at the left of Column C (Columns A, B, and C respectively) are Frozen. To freeze them, click on the View menu and select Freeze (And then select the first 3 columns).
Permissions
Check if the spreadsheet is shared with Anyone with the link can edit permissions:
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Check Dates Incongruences
Make sure the dates are correctly formatted for each week. Usually, the metrics update will fail if the dates were changed manually:
Additional Information
✅ Validate that the template worksheet name provided matches precisely with the Google spreadsheet name.
✅ Ensure that the first column's name is XOID, and the information there is the Assignment ID for each user. If you do not have that information, please create a ticket to Support asking for the Assignment ID of each Contractor/Employee.
✅ After the Email column, you can see the values that are supposed to be shown on the Teamroom metrics, ordered by Week in this case.
✅ A thick vertical line between columns C and D is seen, which means that all columns to the left of column C (columns A, B, and C respectively) are frozen. To freeze them, click on the View menu > Freeze and select the first three columns.
✅ In the template worksheet, do not change the data in column A XOID or the first row (the table headings), as we will not be able to match metrics.
✅ Do not insert empty rows between team members in the template worksheet. This breaks the table, and we cannot read the data below the break.
✅ We will automatically add new team members to the template worksheet.
✅ Use the same template worksheet name for multiple teams if you want to add all their team members in the same worksheet.
✅ Use a different template worksheet name for each team if you want a separate worksheet for each team.
✅ You can use a formula to auto-fill the metric values from the other worksheets or add the values manually, be sure to confirm that all columns from other worksheets are available and that the values can be retrieved without issues.
✅ Enter a new worksheet name or delete the old worksheet template if you want to start over.
✅ Make sure to update Metrics by following the Refreshing Team Metrics article.
Support Agents - Configuring the Testing Datasheets With Customer Data
- Go to the Metrics App.
- Click on Settings.
- On the Google Sheets Settings, go to Sheet URL* and paste the URL that you configured already.
- Mark the Anyone with the link can edit option.
- On Template worksheet* select the name of the tab where you configured the Google Sheet. In this example, it's
MetricsForTeam1
.
- Set the Metric Target per team member for the team.
- In this case, all the agents under
19
units in their metrics are agents that did not achieve the goal.
- In this case, all the agents under
- Create a clone of the Google Sheet that the customer provides you with, and link it to the Metrics Settings. You can use it to troubleshoot metrics issues without performing any changes to the original customer Google Sheet.
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Confirmation
You will be able to review the metrics values and they should match the ones defined in the Google spreadsheet.
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