Attempt to apply for a tournament is failing for a registered candidate

Issue

Registered users won't be able to apply unless they are logged in using the same email they are using for the tournament. Users who are applying on tournament landing pages need to enter their email address into the registration form. If such a user is currently not logged in, the system won't let them pass this step. 

Prerequisites

  1. Tournament platform registration landing page.
  2. User with a registered Crossover account.

Root Cause

As long as an email address belongs to a registered user, the system won't allow the user to use the same address in order to register a new account for a tournament (the application on the tournament page creates a new account automatically). The user will only be able to use a previously registered email address if they are logged in with that address.

Solution

  1. Log in to Crossover portal at https://app.crossover.com/x/login
  2. Repeat application attempt at the tournament landing page.

 

Confirmation: The next application step is presented on the portal.

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