Error: You can not enroll yourself in this course

Overview

The candidate is getting the message 'You can not enroll yourself in this course.' when attempting to start an application on the Crossover Portal for a new job.

Root cause

This error is displayed because the candidate's browser still has cached information from previous attempts.
 

Resolution

  1. Clear your web browser cache
    Below you will find guides that explain how to clear the cache in some of the most popular web browsers:
     
     
  2. Log in to the Crossover portal again using the Technical Screen user ID and password.  
    Note: For each application, the "Invited to Technical Screen" stage provides a different user ID and password. 
 
 

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