Overview
While reviewing timecards content in your Crossover logbook, you may find that timecards are being generated with Title or Application with messages like "Could not get active application title" or "Could not get active window".
This problem is related to the operating system permissions which are preventing WorkSmart from collecting the expected data related to the active window and application process being used.
Prerequisites
- Active contractor using WorkSmart to track time.
Diagnosis
While reviewing timecards information in your logbook, you may notice that the timecard title or the application used shows the messages:
- Could not get active window title
- Could not get active application title
In the logbook overview, timecards will show:
If you try to access the timecard's details, you will find the message in the Title and/or the Application:
Also, while reviewing your contractor dashboard, you may find the same message classified as one of your top Applications used:
Operating system permissions are the ones that prevent WorkSmart from collecting the information related to the active application (both process and window title).
Solution
- You will need to make sure that you are running the latest WorkSmart version for your operating system, uninstall and install the latest version.
- Confirm that WorkSmart is being executed with the right permissions on your operating system:
- For Windows users, please follow the solution provided in Running WorkSmart as an Administrator on Windows article.
- For macOS users, please follow the solution provided in macOS Permissions Preventing WorkSmart From Tracking Time article.
- If you are still facing the same issue, you will need to collect WorkSmart logs and contact Crossover Support:
- On Mac, zip and attach the contents of the folder:
HD/users/<user>/crossoverfiles/logs
- On Windows, zip and attach the contents of the folder:
C:\Users\<user>\AppData\Roaming\CrossoverWorkSmart\Logs
- Create a new ticket for Crossover Support, attaching the zip file containing WorkSmart logs.
- On Mac, zip and attach the contents of the folder:
Confirmation
Once you start tracking time with WorkSmart and timecards are being uploaded, you can access your logbook and confirm that all timecards are generated with the expected details (Title and Application):
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