WorkSmart Not Saving Last 10 Minutes

Overview

While tracking time with WorkSmart, you may find out that after you stopped the application and exit immediately, the total amount of tracked time for the day or week is missing 10 minutes. You can confirm the latest timecards uploaded to Crossover by reviewing your logbook or checking the total logged hours in your Earnings section.

WorkSmart is working as designed, once you stopped tracking time, you need to wait at least till the next time slot to have your latest timecard uploaded.

 

Prerequisites

  • Active contractor using WorkSmart to track time.

 

Diagnosis

Once you stopped tracked time and exit the WorkSmart application immediately if you access your Logbook section in the Crossover portal you won't find the last timecard uploaded.

After stopping tracking time with WorkSmart, timecards are going to be stored locally and uploaded during the next time slot (10 minutes).  If the user stops WorkSmart and immediately exit the application or shut down the computer, the timecards are not being uploaded until the WorkSmart application is started.

 

Solution

Once you stopped tracking time, don't exit the WorkSmart application or shut down your computer immediately, wait at least 10 minutes to give WorkSmart time to upload your latest timecard.

Please notice that if you decide not to wait, WorkSmart will upload your timecard the next time is started, you won't lose any timecards.

 

Confirmation

You can confirm that all your timecards are uploaded by reviewing them in your Logbook section in the Crossover portal.

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